Bug in frontend api for 25% of our users

Resolved
Operational
Started about 1 year ago Lasted 30 minutes

Affected

app.unleash-hosted.com [EU region]
us.app.unleash-hosted.com [US region]
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    On 01/03/2023 we rolled out new functionality to allow users to retrieve all toggles from the frontend-api, including those who evaluated to false. This introduced a severe bug that would ignore strategies if a feature was enabled in an environment. This was brought to our attention and identified at 13:15 on 02/03/2023. We then disabled the feature flag and the endpoint starting working as expected.